WordPress4.5にしたらメディアアップロードでhttpエラーの解決方法

本日、Wordpressをバージョン4.5にして、画像をアップロードするととhttpエラーで、
メディアアップロードができないので、困った
20160413_01

その数分前までは、作業していたので、正常にメディアアップロードはできていました
しかし、更新してすぐに、Wordpress4.5にしてhttpエラーがでたので、

これは、すぐに原因は、バージョン4.5にしたことによるものだと、確信していたので、
これは、調べるよりも、レンタルサーバー会社に問い合わせたほうが解決すると思い、

■サーバーをレンタルしているロリポップに問い合わせたところ、すぐに、解決できました

返信は、数時間後にもらえました、とても速い対応で満足です
内容を予約すると、すでに、英語版で、
WordPress 4.5 では
「/wp-includes/class-wp-image-editor-imagick.php」
というファイルの記述が影響して、メディアのアップロードが
行えないケースがあるとWordPressにて報告されているとの内容でした。

英語苦手なので、読んでません

その内夜を公開しておきます、こまっているひとは、これで解決できるはず

■対処方法として、
「/wp-includes/class-wp-image-editor-imagick.php」を
以下のように
379行目と380行目の記述を修正して、FTPでアップするだけです

※一応、初心者の方のために、補足
テキストエディッタで編集します、Windowsに搭載のメモ超は使用してはいけません。
BOM有りとBOM無しの問題があるので、必ず対応のテキストエディタで修正します
私は、テキストエディッタは、フリーのTerapadを使用してます

元のコードが以下で
———————————————————-
&& defined( Imagick::ALPHACHANNEL_UNDEFINED )
&& defined( Imagick::ALPHACHANNEL_OPAQUE )
———————————————————-

それを新たに、以下のコードに修正するだけです
———————————————————-
&& defined( ‘Imagick::ALPHACHANNEL_UNDEFINED’ )
&& defined( ‘Imagick::ALPHACHANNEL_OPAQUE’ )
———————————————————-

この内容で、修正して、早速アップロードしたら、正常に写真画像がアップロードできました

サーバーロリポップのサポートに感謝です

スポンサーリンク
  • このエントリーをはてなブックマークに追加